Midi Fighter Twister on Snow Leopard (10.6.8)

Follow

As a Class Compliant device the Twister will work straight out of the box with this and all other version of OS X and macOS.

Unfortunately this is not the case for the Midi Fighter Utility and recent versions of it aren't compatible with Snow Leopard. If you are still running this OS on your computer and want to use the MF Utility along the Twister you'll need to use the version in the link below. There will be a prompt asking you to update it when the MFU opens but it is safe to ignore. 

MF Utility 2.55 (10.6.8 compatible)

Have more questions? Submit a request

Comments

Powered by Zendesk