Midi Fighter System Requirements

Follow

The MidiFighter 3D, Spectra and Twister are class compliant, plug and play controllers. 
They will work with any computer that has a USB port and supports MIDI.

These devices are not standalone units and need software to run and handle audio.

The MF Utility needs OS X 10.6.8 / Windows 7 or newer to run.

Have more questions? Submit a request

Comments

Powered by Zendesk